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Introduction

This is a complete step-by-step guide for migrating from GoDaddy IMAP to Office 365 BitTitan’s
migrationwiz. Only mail items are migrated during the migration. If you have any calendars or
contacts you want brought over, you will need to export them as PST files.

Planning Phase 1: Gather All the Necessary Credentials

1. Credentials Checklist
a. Office 365 Global Admin Credentials
b. GoDaddy Admin Credentials
c. All users passwords part of the migration

*Note* BitTitan comes with a tool called Deployment Pro which reconfigures Outlook profiles
after the migration. This can be pushed out either through GPO or email. If you are going to be
pushing this out via GPO you will additionally need:

e. Credentials remote into Primary DC (If applicable)
f. Enterprise Admin Credentials for Primary DC

Planning Phase 2: Gather and Audit all Users part of the Migration

1. Login to the GoDaddy portal with Admin Creds
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Registered Users

Have an account? Sign in now.

2. Scroll Down to “Workspace Email”, Click “Manage All”

4 Workspace Email Manage All >

Free email forwarding for on-sitemed.com

Empty 2

M X X

On-Site

Expires 6/17 /2018

3. You will see your List of Email Address’, Click on Export:

Home Tools v Help =

[N
s
R All Accounts View Email @58 View Calendar ™8 View Files
(N 4 accounts 4 accounts 1 0 accounts l 0 accounts
v ) &b a ~ (%) & Search
Create  CreateMany Create Forward  Export Delete  Switch Plans
v Email Address I Attributes Alerts  Plan Name Usage Relays
» 3 GB / Unlimited 5/250
> 4 GB / Unlimited 0/250
= . 56 MB / Unlimited | 7/250

Free email forwarding for on... | Forward Account

Display. 25 ¥

Email Forwarding - 100 Pack S

Unlimited Business Email m

Email Anywhere / Anytime
Want to setup email on
your phone, Outlook, or

@ other device?

Get Started

View By

Type
. All Accounts
Email Accounts Only
Forwarding Addresses Only
Domains
Plans

Unused Plans
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4. Exportto CSV

N

Export:
Email v
Include:
v Selectdll
v User Name =~ Expires
Account Alerts cc
Plan Forwarding
Usage Catch-all
Relays Auto-Reply ~
File format:
csv v
ST Cancel

5. Edit the CSV to contain 3 Headers:
a. UserName
b. EmailAddress
c. Password

Clipboard M Font IT. Alignment

D POSSIBLE DATA LOSS Some features might be lost if you save this workbook in the comma

)2 - Jx
A B C D E F
1 |EmailAddress UserName Password
2 |starfox@wrajrecords.com Star S m3r1969!| _|
3 Dkong@wrajrecords.com Donkey atrix@1
1
5
3
7
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*Note* You can gather Passwords from Users or choose to reset them in the GoDaddy Portal:

visplay: 29 ¥

JS, 38/5 accounts used, Unlimited GB - Expires: 6/17/2018 Add Account
v Email Address Attributes Alerts | Usage Relays
- + 3 GB / Unlimited 31/250
Unused Plans
2 &, gy nnlinied 0/250 Eonnardina Accante
v “l| & Edit ¥
=” Switch Plans 628 MB t
Last Log\'n: S &
@ Delete 6/14/2018 3:38 am Changﬁiwiord
7 Email Setup Launch:

Center

4 Free Accounts

Prep Work Phase 1: Prepare Office 365

1. Create a net new office365 tenant, tenant will be spun up with the defaulted
.onmicrosoft.com domain. This can be spun up direct with Microsoft or purchased
through a CSP provider

2. Go to Setup>Domains>Add Domain

3. Verify Domain with TXT record provided

4. Select "l will manage DNS records myself" and checkmark the box "Skip this step" when
it ask to place all the remaining DNS settings for you

5. Domain will say "possible service issues”. This is ok. We will add the remaining records
after we cut over MX Records

6. Add Users Manually, Bulk Upload with a Powershell Script or CSV, or with AD Connect
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a. Powershell Script

#Connecting to Exchange Online Account#
Scredential = Get-Credential

Import-Module MsOnline
Connect-MsolService -Credential S$credential

SexchangeSession = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri
"https://outlook.office365.com/powershell-1liveid/" -Credential Scredential -Authentication
"Basic" -AllowRedirection

Import-PSSession $exchangeSession -DisableNameChecking

Create a CSV with the Following Headers:
UserPrincipalName

FirstName

LastName

DisplayName

Password

#Bulk Import Users with Passwords#

Import-Csv -Path 'FilePath' | foreach {New-MsolUser -UserPrincipalName
$ .UserPrincipalName -FirstName $ .FirstName -LastName $ .LastName -DisplayName
$ .DisplayName -Password $ .Password -ForceChangePassword $False}

#Add Alias to Users#

SLiveCred = Get-Credential

$SSession = New-PSSession -ConfigurationName Microsoft.Exchange —-Connecti
dential $LiveCred -Authentication Basic -AllowRedirection
Import-PSSession $Session

Susers = Get-Mailbox

foreach ($a in Susers) {Sa.emailaddresses.Add("$(Sa.alias)@domain.com")
Susers | %{Set-Mailbox $ .Identity -EmailAddresses $ .EmailAddresses}
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#Add Distribution Lists with Members#

Import-Csv -Path 'File Path.csv' | foreach {New-
Distributiongroup -Name $ .Name -PrimarySmtpAddress $ .Address

}

Import-Csv 'File Path.csv' | foreach {Add-
DistributionGroupMember
-Identity $ .DL -Member $ .Alias}

b.AD Connect Setup: https://docs.microsoft.com/en-us/azure/active-directory/connect/active-
directory-aadconnect-get-started-custom

7. Assign Licenses to Users

Prep Work Phase 2: Export Calendar/Contact Info to PST file

Recall with IMAP we cannot migrate Calendar and Contract data. For this reason, | like to
export the data and save a local copy of the OST file for the Outlook profile.

1. Open Outlook

2. At the top of your Outlook ribbon, choose File

Folder View ) Tell me what you want to do

°o— : Meet o
- - =] Team Email

New New ° ! A as
g - § Create New
Email Items ~ &g Junk ‘

New Delete Respond Quick Steps



https://docs.microsoft.com/en-us/azure/active-directory/connect/active-directory-aadconnect-get-started-custom
https://docs.microsoft.com/en-us/azure/active-directory/connect/active-directory-aadconnect-get-started-custom
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3. Choose Open & Export > Import/Export

Open & Export

Open Calendar
Open a calendar file in Outiook (ics, .ves)

Open Outlook Data File
Open an Outiook data file (pst).

Import/Export
&= Import or export files and settings.

Other User's Folder
P Open a folder shared by another user

4. Choose Export to a file

Import and Export Wizard

Choose an action to perform:

port RS ds to an OPML file
Export to a file

N % Import a VCARD file (vcf)
Import an iCalendar (.ics) or vCalendar file (.vcs)
Import from another program or file
Import RSS Feeds from an OPML file
Import RSS Feeds from the Common Feed List

Description -
Export Outlook information to a file for use in
other programs.

N |
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5. Click Outlook Data File (.pst), and then click Next.

Create a file of type:

Comma SeEarated Values

6. Select the name of the email account to export>Select Calendar

Export Outlook Data File X

Select the folder to export from:

a Outlook Customer Manager ~
v

> Inbox (1)

[_7 Sent ltems

(& Deleted Items (120518)

[7] Drafts [93]
> |z, Calendar
> Contacts

Archive (344)

> Conversation History
o gniennnl M

Include subfolders b

‘ < Back ” Next = | ‘ Cancel ‘

10
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7. Click Browse to select where to save the Outlook Data File (.pst).

Export Outlook Data File X

Save exported file as:
Ross\Documents\Outlook Files\backup.pst Browse...
Options
(®) Replace duplicates with items exported
O Allow duplicate items to be created
O Do not export duplicate items

< Back Cancel

8. Leave the Default options and Click Finish

9. Since this is a new PST file you will need to create a password to access it

Create Outlook Data File X

Add optional password

Password: ‘ ‘

Verify Password: ‘ ‘

D Save this password in your password list

10. Follow the Same Steps for your Calendar Items

11
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Prep Work Phase 3: Push out DMA agent

BitTitan comes with a deployment pro agent that automatically configures outlook profiles. This
will bring over autofill settings and signatures for all users. There are two options to push this
out:

a. GPO

b. Email

*Note* If we are deploying the agent via gpo, users will just receive a popup asking them to
authenticate and will reopen outlook after cutover. If we are pushing the agent out via email,
users will receive a message in which they will have to click on a link to install the agent on their
device

1. Login to the BitTitan Portal and Click All Customers on the left-hand column

€ Wéitomplete [ Add > B Ll © Help~ © Purcnase
- provisioning Workgroup
Welcome to MSPComplete
& Getting Started
Learn how to build Runbooks and deliver standardized, repeatable, and profitable services with MSPComplete. Follow the

@ Dashboard below to get started:
B Runbooks
&  Delivery Center " =
B My Tasks . q

. I <
& Personal Feed o ¢ [5)
ul  Reports

1. Create Runbooks 2. Generate Estimates 3. Runbook Execution

ﬁ‘-l All Customers Create Runbooks from your existing documentation, or browse Generate cost estimates prior 10 delivering your Services. Assign, launch, and monitor the status of your §

our Library. delivern
i People
3 Settings

12
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2. Click Add Customer>Fill out Customer Name and primary Domain>Click Save

Add Customer

v Customers

Details

provisioning Workgroup

®

Select Country

Select Industry

Select Company Size

Follow Steps 3-14 if you are choosing to deploy the agent via GPO
3. Remote into Primary DC

4. Open Browser and Login to BiTitan.com

5. Go to All Customers>View Users on the Customer you created

6. Click “Enable the Device Management Agent”

13



T-N@S@

=" el 0209090
Add Users to begin managing your Customers and delivering Services.

Add Users Through an Endpoint

Automatically add Users and Groups from existing cloud services.

Enable the Device Management Agent

Deploy a lightweight Agent on devices to import Users.

Add Users in Bulk

Import Users through a CSV file, without accessing your Customer's production environment.

Add Users with Quick Add

Add a User to MSPComplete.

vV NN

7. Follow the steps from the following KB Article which walks you through setting up a new
share, placing the exe in the share, creating the gpo, and scheduling it to run
-https://help.bittitan.com/hc/en-us/articles/115008110847

Add Users with a Device Management Agent

o By using the Device Management Agent, you agree to comply with BitTitan's User Agreement.

v Device Management
Instructions

Installing with a Group Policy Object (GPO).

1. Save the Device Management Agent setup file (i.e., BitTitanDMASetup_60577C0AS54BAST2_exe) to a
network share folder.
The folder needs to be accessible for all Users on the network.

2. Create a GPO that executes the DMA setup file on an Active Directory Organizational Unit's computers with

an immediate scheduled task.

Script Parameters:
\\[path-to-
BitTitanDMASetup_60577C0AS54BA572_ exe]\BitTitanDMASetup_60577C0AI54BASTZ_exe

14
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8. Monitor users that successfully have the agent installed by going to Customers>Select
customers>Manage>Device Management>Deployment pro

*You will need to put in the destination domain and add the 365 endpoint*

DeploymentPro Cancel

What is DeploymentPro, and how does it work?

E DeploymentPro is a cloud-based solution that remotely configures and manages Users’ Outlook profiles.
« To start using DeploymentPro, launch the Device Management Agent.

+ Once installed on Users' devices, set up the module to automate the configuration of all Users’ Outlook profiles.

@ Launch DeploymentPro for UserActivation to View Legacy Projects

Module Configuration

estination Domain Name

v
@

The field cannot be lefi blank

Select Destination Endpoint

Office365

Once users start to login to their computers, their device will be registered and their primary upn
will be listed “Primary Email Address” column

Search Customers

Cardinal Transport

"4 A Customers Cardinal Transport Device Management D e p I Oym e nt PI’O

veryi
O Oveniew DeploymentPro

SERVICE MODULES Use BitTitan PowerShell to schedule DeploymentPro for a large number of mailboxes. Read more.

S HealthCheck for Office 365 125 80 1999058

=  DeploymentPro Total Users Total Devices Licenses Owned

15
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A customers © Cordinal Tansport © Device anagement  DEPlOyMeNtPro

DeploymentPro

Use BitTitan PowerShell to schedule DeploymentPro for a large number of mailboxes. Read more

126 80 1999059
Total Users Total Devices Licenses Owned
Primary Email Address Destination UPN

Module Status

Scheduled on Apr g, 2018 11:30am

Scheduled on Apr 7, 2018 12:15pm

Scheduled on Apr 7, 2018 9:45am

Not scheduled

Not scheduled

Not scheduled

®

Settings

Sort ¥ 4

®

9. Users computers will be listed and will have a "heartbeat". Once a user signs into the device
their email will be tied to the device in a one to one relationship.

w Customers Cardinal Transport Device Management C om p Uters

Services Computers

80 Computers
Computer Name Number of Users
AR-DD4 1
ARDEB 1
AS400CONSOLE-PC 1
BILLINGSARAH 1
BROKERAGEJD-CR 1

T

Agent Status

* |f a status shows a ? symbol it most likely means the computer is shut down and the tool
hasn’t been able to find a heartbeat in over 4 hours*

CRDTAPP 2

CRDT-AR-DLS 1

16
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11. Once all users have populated and have the DMA agent installed, Schedule the cutover
date for the agent to run on their computer. (This is after you point MX records to office365)

Schedule DeploymentPro

Schedule for Profile Cutover

This is the date and time scheduled for DeploymentPro to run on your Users’ machines. The module will install on their devices at the
next heartbeat, and then run silently until:

Select a date

May 11th, 2018 11:30am

The time specified is (America/Denver).

Subscribed Users (no license required): 1

License Consumption
Users License per User Total Licenses Required
1 1 0

User Destination Email

The Destination email address is the email address of the new profile after it has been configured.

Source Email Destination User Principal Name

Cancel Schedule Cutover

*Note™ If there are multiple domains involved you will have to go to “settings” in the deployment
pro page and change the domain for the users who need the separate domain

17
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n

12. Once the agent is scheduled successfully, all users should change to a status of "running

Total Users Total Devices Licenses Owned
Primary Email Address Destination UPN Module Status @ @
Scheduled on Apr 30, 2018 9:15am 0 0
Scheduled on Apr 30, 2018 4:00pm 0 0
Scheduled on Apr 30, 2018 9:15am 1 0

Scheduled on Apr 30, 2018 9:15am ( 0

13.If the status does not say "running" but remains in "scheduled" reschedule again until it
moves into a running status

14.If users are not being picked up with the GPO, troubleshoot with one remote end user:

Run Gpresult on their computer to see if the GPO is running

If the GPO is running, try running the exe manually to see if it is blocked but a firewall
setting

If it is blocked, then create an exception to the firewall to allow the exe to run.

If it is not being blocked check to see if there are any web proxy settings that may be
blocking communication back to bittitan

15. *This completes the steps for setting up DMA via GPO. If you have completed this
successfully then move on to the next section. If you are deploying the agent via email, follow
steps 16-26.*

Deploying DMA via EMAIL

16. In the BitTitan portal, go to All Customers and select the customer you created

18
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17. Click Add Users Through an Endpoint
— el
Add Users to begin managing your Customers and delivering Services.

Add Users Through an Endpoint

Automatically add Users and Groups from existing cloud services.

Enable the Device Management Agent

Deploy a lightweight Agent on devices to import Users.

Add Users in Bulk

Import Users through a CSV file, without accessing your Customer's production environment.

Add Users with Quick Add

‘Add a User to MSPComplete.

vV NV N

18. Click Manage Endpoint>Add Endpoint

19. Find the GoDaddy IMAP endpoint from the “Find my service Provider” dropdown:
Exchange 2003

Exchange 2007

Exchange 2010

Giacom

Exchange 2010

Exchange 2013

GoDaddy
Exchange 2007

Exchange 2010

IMAP S

IMAP v

rom the drop-down menu, select a Service Provider. Based on your selection, we will complete the remaining fields
or you.

ndpoint Type

19
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é'h New Endpoint

Endpoint Name

GoDaddy

Service Provider

IMAP v

From the drop-down menu, select a Service Provider. Based on your selection, we will complete the remaining fields
for you.

Endpoikﬂype

IMAP v

Server Name

imap.secu reserver.net

Server Port

993

¥ UsessL

Close Add

*Note* This will autofill the server name and port

20
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20. From here you can select users by checking the box next their name and selecting “Enable
Device Management Through Email”

1 Selected Apply User Migration Bundle License Delete Users Enable Device Management Through Email
=] Primary Email Addre... User Principal Name First Name Last Name DMA Status License Expiration
Demouser@test.com Demouser@test.com Demo User (7] None

21.Enter a valid email in the “From” section of the template and click Send Email

Enable Device Management Through Email

e T Ty S ST Py e I AT

Email details
To change the list of recipients, go back to the Users list and update your selection.

You can use Markdown syntax to format your email. Click here for help.

Demouser@test.com

s
From
Fromy
Enter email address
Subject
Action required: Install the BitTitan Device Management Agent on your computer.
Enter email subject
- Insert a placeholder -
e
Hello {user_first_name},
# Important Announcement
We are currently planning a series of updates and improvements to our IT Services.
A

21
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*Note* You can white label this email specific to the content you want users to receive. This
email is specific to the user and cannot be forwarded to another user for them to click on the
link for the exe file. The User Simply clicks on a link to open a new page and clicks on one more
link to download the exe file

22. Monitor users that successfully have the agent installed by going to Customers>Select
customers>Manage>Device Management>Deployment pro

*You will need to put in the destination domain and add the 365 endpoint*

DeploymentPro Cancel

What is DeploymentPro, and how does it work?

E DeploymentPro is a cleud-based solution that remotely configures and manages Users’ Outlook profiles.
« To start using DeploymentPro, launch the Device Management Agent.

« Once installed on Users' devices, set up the module to automate the configuration of all Users’ Outlook profiles.

@ Launch DeploymentPro for UserActivation to View Legacy Projects

Module Configuration

Destination Domain Name
@
-
The field cannot be left blank
Select Destination Endpoint
Office365 i

Once users start to login to their computers, their device will be registered and their primary upn
will be listed “Primary Email Address” column

Cardinal Transport

W A Customers Cardinal Transport Device Management D e p I Oym e nt P ro

O Ovenew DeploymentPro

SERVICE MODULES Use BitTitan PowerShell to schedule DeploymentPro for a large number of mailboxes. Read more.
®¢  HealthCheck for Office 365 1 25 80 1 9990 58

& DeploymentPro Total Users Total Devices Licenses Owned

22
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A customers © Cordinal Tansport © Device anagement  DEPlOyMeNtPro

DeploymentPro Settings

Use BitTitan PowerShell to schedule DeploymentPro for a large number of mailboxes. Read more

126 80 1999059

Total Users Total Devices Licenses Owned

Sort ¥ 4

Primary Email Address Destination UPN Module Status @ @ @ @

Scheduled on Apr g, 2018 11:30am 0 0 1 0
Scheduled on Apr 7, 2018 12:15pm 0 0 1 0
Scheduled on Apr 7, 2018 9:45am 0 0 1 0
Not scheduled 5 0 0 0
Not scheduled 0 0 0
Not scheduled 0 0 0

23. Users computers will be listed and will have a "heartbeat". Once a user signs into the device
their email will be tied to the device in a one to one relationship.

w Customers Cardinal Transport Device Management C om p UterS

Services Computers

80 Computers
Computer Mame Number of Users Agent Status
AR-004 1 4
ARDEB 1 v
AS4A00CONSOLE-PC 1 v
BILLINGSARAH 1 L
BROKERAGEJD-CR 1 v

* |f a status shows a ? symbol it most likely means the computer is shutdown and the tool hasn’t
been able to find a heartbeat in over 4 hours*

CRDTAPP 2 v

CRDT-AR-DLS 1 7]

23
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24. Once all users have populated with a and have the DMA agent installed, Schedule the
cutover date for the agent to run on their computer. (This is after you point MX records to
office365)

Schedule DeploymentPro

Schedule for Profile Cutover

This is the date and time scheduled for DeploymentPro to run on your Users’ machines. The module will install on their devices at the
next heartbeat, and then run silently until:

Select a date

May 11th, 2018 11:30am

The time specified is (America/Denver).

Subscribed Users (no license required): 1

License Consumption
Users License per User Total Licenses Required
1 1 0

User Destination Email

The Destination email address is the email address of the new profile after it has been configured.

Source Ema Destination User Principal Name

Cancel Schedule Cutover

*Note* If there are multiple domains involved you will have to go to “settings” in the deployment
pro page and change the domain for the users who need the separate domain

25. Once the agent is scheduled successfully, all users should change to a status of "running"

24
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25 25 1999059
Total Users Total Devices Licenses Owned
U Primary Email Address Destination UPN Module Status @ @

Scheduled on Apr 30, 2018 9:15am 0 0
Scheduled on Apr 30, 2018 4:00pm 0 0
Scheduled on Apr 30, 2018 9:15am 1 0
Scheduled on Apr 30, 2018 9:15am 0 0

26.If the status does not say "running" but remains in "scheduled" reschedule again until it
moves into a running status

Prep Work Phase 4: Setup BitTitan Project

1. In BitTitan Portal, Open MigrationWiz by clicking on waffle icon at top of the page>Click
Mailbox Migration

m ® Feadback @ Help~- O Purchase i

F
= N
Computers Gatewavs Document Migration Public Folder Cloud Storage
= I Li =
Migraticn Migration
=4 B~ e
DeploymentPro UserActivation for HealthCheck fior
ast Mame csp Office 365
e Ex
User E&’ n
HealthCheck for UserActivation Mailbax Migraticn
Azure
L —
Personal Archive
-

25
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Select a Project Type:

Create a Mailbox Project

‘With Mailbox Projects, automatically migrate data related to the
User mailbax. With most configurations you can migrate email,
calendars, contact...

Create a Public Folder Project

Public Folder Projects fully automate the migration process of
maving Public Folders, including Public Folder structure and
permissions, from one..

Create an Archive Migration Service Project

With Archive Migration Services, you can migrate large-scale,
enterprise-level archived...

Create a Callaboration Project

‘With Collaboration Projects. you can automatically migrate data
from one collaboration platform to...

2. Click Create Project>Select ‘Create a Mailbox Project’

Create a Document Project

With Document Projects, automatically transfer all your data
(including your entire folder hierarchy) from one cloud storage
solution 1o anothe...

Create a Personal Archive Project

With Personal Archives, you can automatically migrate 2l of your
archived...

Create a Cloud Storage Project

With Cloud Starage Prajects, migrate large-scale and
unstructured...

Create A Database Project

Database Projects enable you to migrate on-premises Microsoft
SQL Server 2005 and later to Microsoft SQL Server 2012 and
later, 2s well as Microsoft...

H E B E

3. Name the Project and select your customer from the dropdown>Click Next Step

up Mailbox

With Mailbox Rrojects, automatically migrate data related to the User mailbox. With most configurations you can migrate
email, calendars, contacts, journals, tasks, and notes.

Project Name*

Hosted Godaddy

Customer*

ON-site v New

¥ Next Step

26
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4. If you followed the steps for email deployment for the DMA agent you should be able to select

your endpoint from the dropdown. If you did not, Select New and fill out the fields as shown
below:

Exchange 2003 I
Exchange 2007

Exchange 2010

Giacom

Exchange 2010

Exchange 2013

GoDaddy
Exchange 2007

Exchange 2010

IMAP k‘

IMAP v

rom the drop-down menu, select a Service Provider. Based on your selection, we will complete the remaining fields
or you.

ndpoint Type

27
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é'h New Endpoint

Endpoint Name

GoDaddy

Service Provider

IMAP v

From the drop-down menu, select a Service Provider. Based on your selection, we will complete the remaining fields
for you.

EndpoibType

IMAP M

Server Name

imap.secu reserver.net

Server Port

993

¥ UseSSL

Close Add

28
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5. In the Destination Settings, Click New, and add the 365 endpoint. Providing the admin
credentials

A'E'B New Endpoint

Exchange server, Office 365, etc.). Endpoints can be reused for projects across all BitTitan products, and are
managed from the Custormer Dashboard. Endpoints allow you to perform migrations, the discovery of Users and
Groups, and administrative action.

© B Learn About Adding Endpoints

Details

Endpoint Narme

365

I you dor't know your Server Type, dick the button:

+ Find My Service Provider

Endpoint Type

Office 365 v

® Provide credentials
Providing credentials at the endpaint level allows you to have a centralized set of credentials that can be used

across BitTitan products.

() Do not provide credentials.
If credentials are not provided at the endpoint level, you will need to provide per-user credentials when using
the endpoint as part of your projects.

Administrator Usernarme

Enter an administrator username

29
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6. Click “Save and Go to Summary” This tells you what is eligible to move and gives you
additional KB articles you can reference. Click ‘Save Project’ when you are ready to
proceed

E PROJECT SUMMARY

SOURCE

DESTINATION
= a

IMAP Microsoft Office 365

Items Available for Migration

 Mail
@ Migration Guides @ Need Help?
Here are relevant Migration Guides: Here are some Knowledge Base articles related to your current
* IMAP to Office 365 Migration Guide configuration:

How do | migrate from/to an IMAP server?

How do | migrate from an IMAP system with administrative
credentials?

How do | migrate items other than email when migrating from an
IMAP server?

How do | turn off Calendar Assistant in Office 3657

More Articles: Knowledge Base

30
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7. Add items to your project. If you already added users to the MSP complete portal either
through GPO or Bulk Upload. You can select “Add from MSP Complete”. If you have not yet,
then you can bulk upload a CSV file

# Edit Project =

Add items to your Project.

%o Add From MSPComplete

I L e sers from an exstng Customer

* Quick Add

u

Add one item at a time.

*» Quick Add
*s Bulk Add

4 Bulk Add

Use our online spreadsheet, or a file of your own, to add

it -
Click the "Add" menu in the toolbar, and select an option for o

adding items. =, Autodiscover ltems

Use MigrationWiz to automatically discover all of your items.

8. Audit User names and Domains (Make sure they match 365). Clean up user-list. Verify the
Source and Destination domains are correct.

9. Select All Users>Verify Credentials

# EditProject ~

Source Email Y& Verify Credentials Last Updated Migrated User Migration Bundl...  Error Status

53} Dernouser@test.cam B8 Trial Migration May 9, 2018 2:49pm 0 bytes No @ 0 B Not Submitted £

=
& Pre-Stage Migration

E Full Migration

2 Retry Errors
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10. There are numerous errors that could appear here. Most of the steps | made for prep work
will make it so that you avoid most of these errors. Refer to BitTitans KB articles for most
common errors and how to troubleshoot. hitps://help.bittitan.com/hc/en-
us/sections/115003465187-Mailbox-Error-Lookup?page=2

Unsuccessful verification will show a “Failed” Message

# EditProjecc ~
Source Email Destination Email Last Updated Migrated User Migration Bundl...  Error Status
= Demouser@test.com Demouser@test.onmicr...  May 9, 2018 2:53pm 0 bytes No @ 0 A Failed & u

You can click on the Failed icon to show a detailed message of what failed

DEMOUSER@TEST.COM CROSOFT OFFICE 365 TO MICROSOFT OFFICE 365 MIGRATION LED a

FOLDER SUMMARY MIGRATED ITEMS & MIGRATION ERRORS

No Data. Type Success Errors h& k]

This item hasn't started migrating.. Tota 00 bytes) 0 (0 bytes)

0 of O folders completed. 8

@ Learn More

Click on “Learn More” to access BitTitan’s Relevant kb articles specific to the error:

© OFFICE 365 USER NAMES SHOULD ALWAYS BE SPECIFIED AS EMAIL
ADDRESSES

Office 365 user names should always be specified as email addresses: This error indicates that the specified Office
365 user name is invalid. Office 365 requires users to log in with an email address, not a user name as in "John
Doe" or "domain\johndoe”.

Resolution:

We recommend the following:

1. If using administrative credentials for Office 365, check the admin user name specified on your project.

2. If not using administrative credentials for Office 365, check the mailbox owner user name specified on the
mailbox.

3. In all cases, make sure the user name work when logging in at https://login.microsoftonline.com.

Close
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Successful Verification will show a “Completed(Verification)” message

Source Email Destination Email Last Updated Migrated User Migration Bundl...  Error Status

! accounts-payable@vel...  accounts-payable@vel.. May G, 2018 2:52pm 267.17 KB No @ 0 v Completed (Verifica... s

11. After all users have successfully completed verification, Select All users>Click on the
Hamburger icon at the top of the toolbar> Click Subscribe Users

+ o

Source Email Destination Email (Bl 4 HealthCheck

Ld Demouser@test com Demouser@test anmicr.. W ay iy e oy | P

12. This will bring you back to the MSP complete portal. Select all users>Click Apply User
Migration Bundle

1 Users

1 Selected Apply User Migration Bundle License Delete Users Enable Device Management Through Email
= Primary E e User Princ e First Name Last Name DM atus L
v Demouser@test.com Demouser@test.com Demo User (7] !

13. This takes a couple of minutes to propagate but after, in the migrationwiz portal the “User
Migration Bundle” column will change from “No” to “Yes”

User Migration Bundl...

ey
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14. Go to Edit Project>Advanced Settings>Set Maximum # of Concurrent Migration (Guideline 3
per 1Mbps of Bandwitth)>Save

A PZRFORMANCE

Preferred BitTitan Datacenter: @

United States Y

Maximum number of concurrent migrations: @

10

Maximum number of errors per migration: @

10

LJ Do notretry errors. @

Migration Phase 1

1. Preferably start at beginning of the week to bring over a bulk of the mail, plan for domain
cutover on Friday evening

*Note* During a pre-stage Pass BitTitan is simply making copies of mail in 365. The user will
experience no loss of data during this time*
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2. Select All Users>Click on the start button>Pre-stage Migration

& Source Email & Verify Credentials Last Updated Migrated User Migration Bundl... [

Ld Dernouser@test.cam £ Trial Migration May 9, 2018 2:53pm 0 brytes Yes
& Pre-Stage Mig
= Full Migration

#* Retry Errors

3. Select a time range from the dropdown of prior to 90 days>Start Migration

» Start Pre-Stage Migration

die S TLEITTS, cpalat d 1a1Le] al W oyed 5 LS AOET TLEINS are algled DeCdUse
they do not change, but typically represent the majority of the data. Use this type of migration before MX record
cutover. Fill the mailbox with older email; this reduces the amount of data to migrate after cutover

1 Items Selected 0 will migration using licenses.

0 Cannot Migrate 1 will migrate using subscriptions.
Select what you want to migrate: @ Remember my selection for this Project
4= Mail

Migration Scheduling

Migrate iterns with a date that is earlier than the specified date. @

Zvs Azo v

Automnatically start the migration at @

X Cancel ' Start Migration

4. This will give you a status bar and show the amount of data moved over in the “bytes”
column. If any users fail, it's usually do to server timeout. Simply rerun the pre-stage pass on
these users to restart where it left off. If you click on any user’s name, you can see metrics like
upload speeds:
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MIGRATION HISTORY DURATION AND SPEED

Statistic Source Destination

3 minutes

o m = W g B Data Speed 3 MB/hr 46 MB/hr

B = = W ¥ 8 @ Performance Analysis

Full Misration ErTTe.

5. Once the pre-stage migration has run for all users and is in a "Completed" Status

P S R

6. Next we are going to perform a full migration to bring over the remaining copies of mail.Select
All users>Click on the start button>Full Migration

Ld Source Email ¥ Verify Credentials Last Updated Migrated User Migration Bundl... [
Ld Dermouser@test.com & Trial Migration May 9, 2018 2:53pm 0 bytes Yes
Pre-Stage Migration

Full Migration

/7 Retry Errors
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8. Confirm all users go into a "Completed” Status

Migration Phase 2: MX Cutover

1. At Designated time, login to DNS provider and change you MX records to point to
Office365
a. You can find this in the 365 Admin Center by going to Setup>Domains
b. Office365 MX record follow this format Domain-
com.mail.protection.outlook.com

2. Run another Full Pass. This will perform a delta sync to pull over any residual data that
may have been missed.

Migration Phase 3: Post Migration Cleanup

1. Audit Destination Environment Mailflow for Inbound/Outbound Mail
2. Login to BitTitan>Go to All customers>Select customer>Manage>Device

Management>Deployment Pro

3. Make sure DMA status has moved into "Completed" status. If in "error" status it means
the users failed authentication 3x. Reschedule the tool to run at the next time interval
available
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A customers o CEl > bevieeManegement © DEPlOyMENtPro

DeploymentPro Settings
Use BitTitan PowerShell to schedule DeploymentPro for a large number of mailboxes. Read more x
Total Users Total Devices Licenses Owned
p Schedule Cutove Sort ¥ Q

& Primary Email Address Destination UPN Module Status @ @ @ @

Scheduled on May 4, 2018 1:00pm 0 0 1 0
Scheduled on May 7, 2018 11:00am 0 0 1 0
Scheduled on May 7,2018 11:00am 0 0 1 0
Scheduled on May 7,2018 11:00pm 0 0 1 0
Scheduled on May 4, 2018 1:00pm 0 0 1 0
Scheduled on May 4, 2018 1:00pm 0 0 1 0

4. Relaunch Outlook and you will see your new profile listed. You can now import your PST
file into the new outlook profile. Go to file>Open&Export>Import/Export

Qpen

Open Calendar

== Open a calendar file in Outiook (ics, .vcs

Open Outlook Data File

Open an Outlook data file (pst

Print

Feedback

Import/Export
—
&= Import or export files and settings.

Support

Office Account
Other User's Folder

Open a folder shared by another user

Options P
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5. Select Import from another program or file

Import and Export Wizard

Choose an action to perform:

Export RSS Feeds to an OPML file
Export to a file
Import a VCARD file (vcf)

Import an iCalendar (ics) or vCalendar file (vcs)
ort from another program or file

Import RSS Feeds from an OPML file
Import RSS Feeds from the Common Feed List

Description

Import data from other files, such as Outlook data
files (PST) and text files.

< Back Next > | ‘ Cancel

6. Select PST

Select file type to import from:

Comma SeEarated Values
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7. Browse for the file path in which you saved the Calendar/Contact Exports

File to import
Ross\Documents\Outlook Files\backup.pst Browse...
Options
@ Replace duplicates with items imported
() Allow duplicates to be created

O Do not import duplicates

8. Import the file into the correct profile

9. Verify your Calendar/Contacts Imported Successfully

10. Send out guides on reconfiguring mail on Iphone/Andriod:
a. https://support.office.com/en-us/article/set-up-email-using-the-ios-mail-app-
7e5b180f-bc8f-45cc-8dal-5cefcle633dl
b. https://support.office.com/en-us/article/set-up-email-in-android-email-app-
71147974-7

11. Perform and account clean up that is required
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