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Introduction

There are many customers looking to migrate off of BAE/Silverskys hosted exchange platform.
Migrating from this platform is fairly simple and upload speeds are far quicker than your typical
exchange environment. This is a step-by-step guide for migrating to Office 365 using the tools
from BitTitan

Planning Phase 1. Gather All the Necessary Credentials

1. Credentials Checklist
a. Office 365 Global Admin Credentials
b. Provisor Admin Credentials
c. BitTitan credentials
d. DNS Login Credentials

*Note* BitTitan comes with a tool called Deployment Pro which configures Outlook profiles after
the migration. This can be pushed out either through GPO or email. If you are going to be
pushing this out via GPO you will additionally need:

e. Credentials to Remote to Primary DC (RDP, TeamViewer, LogMeln, Splashtop, etc)
f. Enterprise Admin Credentials for Primary DC

Planning Phase 2: Gather and audit all Users part of the Migration

1. Gather Users List in CSV format, Export from the Provisor

2. If using AD Connect with password sync users will have the same password as their on
prem active directory. However, if not using AD Connect then you will need to get a list
of passwords from BAE users or notify them of what their password will be in 365

3. Gather Distribution List with members of Distribution list in CSV format

4. Verify Organizational Units in Active Directory that will be a part of the GPO/AD Sync

3
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5. Take note of any 3rd partner connectors for email filtering: Symantec, Barracuda, etc.
Look up necessary steps for creating connectors in 365

6. Define MX Cutover Time (Typically recommend Friday Evening)

Prep Work Phase 1: Prepare Office 365

1. Create a net new office365 tenant, tenant will be spun up with the defaulted
.onmicrosoft.com domain. This can be spun up direct with Microsoft or purchased
through a CSP provider

2. Go to Office 365 Admin Center>Setup Domains>Add Domain

3. Verify Domain with TXT record provided to DNS provider

4. Select "l will manage DNS records myself* and checkmark the box "Skip this step" when
it ask to place all the remaining DNS settings for you

5. Domain will say "possible service issues”. This is fine. We will add the remaining DNS
records after the MX cutover

6. Add Users: Manually, Bulk Upload with a Powershell Script, Bulk Upload with CSV, or
with AD Connect

a. Powershell Script

#Connecting to Exchange Online Account#
Scredential = Get-Credential

Import-Module MsOnline
Connect-MsolService -Credential S$credential

SexchangeSession = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri
"https://outlook.office365.com/powershell-1liveid/" -Credential S$credential -Authentication
"Basic" -AllowRedirection

Import-PSSession $exchangeSession -DisableNameChecking




T-N@s@

Create a CSV with the Following Headers:
UserPrincipalName

FirstName

LastName

DisplayName

Password

#Bulk Import Users with Passwords#

#Bulk Import Users with Passwords#

Import-Csv —-Path 'FilePath' | foreach {New-MsolUser -UserPrincipalName
$ .UserPrincipalName -FirstName $ .FirstName -LastName $ .LastName -DisplayName
$ .DisplayName -Password $ .Password -ForceChangePassword $False}

b. AD Connect Using Custom Settings: https://docs.microsoft.com/en-
us/azure/active-directory/connect/active-directory-aadconnect-get-started-custom

7. Apply Licenses to Users by going to Active Users>Bulk Select Users>Click Edit Product
Licenses

Home > Active users Bulk actions
34 users selected

<l [« [«] [&] [®] [®] [«] [&] [&] [R] [&] [«
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8. Click Add to existing product licenses Assignments

Assign products

34 users selected

select zn ootion

Replace existing product license assignments

®)  Add to existing product license assignments

9.Toggle on the Appropriate License and Click Add



Add to existing products

34 users selected

A MNOTE: Once new users are set up for Skype for Business PSTN Calling, assign
them a phone number in the Skype for Business admin center. (If you don't see
them there, check back in a few minutes.)

You don't have any licenses available. To purchase
additional licenses, please contact your partner(s).

You don't have any licenses available. To purchase
additional licenses, please contact your partner(s).

You don't have any licenses available. To purchase
additional licenses, please contact your partner(s).

I Off

I Off

You don't have any licenses available. To purchase
additional licenses, please contact your partner(s).

10. Bulk Upload Distribution List (If applicable)

#Add Distribution Lists with Members#

Import-Csv -Path 'File Path.csv' | foreach {New-
Distributiongroup -Name $ .Name -PrimarySmtpAddress $_ .Address

}

Import-Csv 'File Path.csv' | foreach {Add-
DistributionGroupMember
-Identity $ .DL -Member $ .Alias}
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Prep Work Phase 2: Prepare Source/Destination for BitTitan

1. Contact BAE support (supportdb@silversky.com) to set admin user with full
impersonation rights for all accounts

“‘Hey Team,

Partner:
Customer:
BAE Product: (ex.BAE Systems 2010 Exchange 25GB)

| am performing a migration for this customer. In checking the admin user for BAE, | see that
they do not have sufficient permission to impersonate the users mailboxes (This avoids us
having to get creds for each user). We just need to run this powershell script for the admin user
for this account:

Can you please run this command for the account:
Get-Mailbox -ResultSize Unlimited | Add-MailboxPermission -AccessRights FullAccess -User
<admin user>

Please let me know if you have any additional questions.
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2. If this is a smaller migration, you can also do this manually in the provisor for each user: To

give the admin user full mailbox rights to each Users, double click on the User > Packages >
Highlight Exchange > Edit > Click

"Launch Mailbox Rights Management" > add the cusrpt and give it Read and Full access

General Address
Telephones Organizatian Member Of Packages
Packages:

EE|Packages Packagesb—
=/ PlatinumsGB ) °+ Subscribe...
[ Customer Supplies Outla...
lFs| Exchange
iz :
i3 Exchange ActiveSyne " Unsubscribe
'@' Change...
Application
i Add
¥ Edit..
= Rermove

i cancel & apply @ Help

General E-mail Addresses  Limits

f;-"i EBizenbery, Clay

Exchange Yersion 2013

Mailbox Resource Type| Usar Mailbox e

[Hide from Exchange address lists

-Protacals

[V POFP3 l&mm
MAP Block non-cached access
[V HTTP WA Settings...
~Forward Mail
@Nnne
CFDrward To: modify...
Deliver messages to both forwarding address and
mailbox
~Mailhox Rights
Launch Mailhox Rights Management ..

3 cancel ¥ Apply @ Help
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Flease selectitemns from the list of Available ltems. Your selections will appear in the Selected tems
list helow.

Path: Coulson Excavating ﬂ
Criteria: 50 j ! Recursive Search
Available tems:
Marme ¥ | Path
HB - ey S —
L
L
A ., . r - e v
i Aed Select Al
Selected Items
MHame Path
== Remove
v ox
1 |
0 Add =3 Rermove
Permissions

Read and Full Access

Send As

Send On Behalf Ik

NI

v ox

3. Change Send/Receive size in office 365 to max of 150m: hitps://help.bittitan.com/hc/en-
us/articles/115008108047

*Note* Make sure you are still connected to exchange online in powershell

#Change Send/Receive Size#

Get-Mailbox | Set-Mailbox -MaxReceiveSize 150MB -MaxSendSize 150MB

10
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4. Set Impersonation on Office365. This will allow you to use admin creds to impersonate all
mailboxes. With this in place you will not need creds for all individual users

#Setting Impersonation#
Set-ExecutionPolicy Unrestricted
$LiveCred = Get-Credential

$Session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri
https://ps.outlook.com/powershell/ -Credential $LiveCred -Authentication Basic -
AllowRedirection

Import-PSSession $Session
Enable-OrganizationCustomization

New-ManagementRoleAssignment -Role "ApplicationImpersonation”" -User admin@domain.com

Prep Work Phase 3: Push out DMA agent

BitTitan comes with a deployment pro agent that automatically re-configures outlook profiles.
This will bring over autofill settings and signatures for all users. There are two options to push
this out:

a. GPO

b. Email

*Note* If we are deploying the agent via gpo, users will just receive a popup asking them to

authenticate to reopen outlook after cutover. If we are pushing the agent out via email, users will
receive a message in which they will have to click on a link to install the agent on their device

11
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1. Login to the BitTitan Portal and Click All Customers on the left-hand column

C "! ﬁ‘s‘ﬁz'dmpleu m # Feedback @ Help~- © Furchase - “
= Provisioning Workgroup
=

Workgro

hormep Welcome to MSPComplete
&  Getting Started
Learn how to build Runbooks and deliver standardized, repeatable, and profitable services with MSPComplete. Follow the
& Dashboard below to get started:
B Runbooks
#  Delivery Center
— s —m r—
My Tasks . 1
L]
& Personal Feed o . I
|
ul  Reports
1. Create Runbooks 2. Generate Estimates 3. Runbock Execution
& Al Customers Create Runbooks from your existing documentation, or browse Generate cost estimates prior to delivering your Services. Assign, launch, and monitor the status of your §
our Library. delivery.

i People
£ Settings

2. Click Add Customer>Fill out Customer Name and primary Domain>Click Save

Add Customer

~ Customers
Details

Workgroup Name
provisiening Workgroup

Primary Lecation (Optional)

Select Country h
Primary Industry (Optional)
-
Select Industry
Company Size (Optional)
Select Company Size h
|

12
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Follow Steps 3-15 if you are choosing to deploy the agent via GPO
3. Remote into Primary DC

4. Open Browser and Login to BiTitan.com

5. Go to All Customers>View Users on the Customer you created

6. Click “Enable the Device Management Agent”
] NN T —
Add Users to begin managing your Customers and delivering Services.

Add Users Through an Endpoint

Automatically add Users and Groups from existing cloud services.

Enable the Device Management Agent

Deploy a lightweight Agent on devices to import Users

Add Users in Bulk

Import Users through a CSV file, without accessing your Customer's production environment

Add Users with Quick Add

Add a User to MSPComplete.

13
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7. Follow the steps from the following KB Article which walks you through setting up a new

share, placing the exe in the share, creating the gpo, and scheduling it to
run:https://help.bittitan.com/hc/en-us/articles/115008110847

Add Users with a Device Management Agent

o By using the Device Management Agent, you agree to comply with BitTitan's User Agreement.

v Device Management
Instructions

Installing with a Group Policy Object (GPD).
1. Save the Device Management Agent setup file (i.e., BitTitanDMASetup_60577COAS54BAST2_exe) to a

network share folder.

The folder needs to be accessible for all Users on the network.

2. Create a GPO that executes the DMA setup file on an Active Directory Organizational Unit's computers with
an immediate scheduled task.

Script Parameters:
\W[path-to-
BitTitanDMASetup_60577C0A954BA572_ exe]\BitTitanDMASetup_60577C0AIS4BASTZ_exe

8. Monitor users that successfully have the agent installed by going to Customers>Select

customers>Manage>Device Management>Deployment pro
*You will need to put in the destination domain and add the 365 endpoint*

DeploymentPro

What is DeploymentPro, and how does it work?

E DeploymentPro is a cleud-based solution that remotely cenfigures and manages Users’ Outlook profiles.
= To start using DeploymentPro, launch the Device Management Agent.

» Once installed on Users’ devices, set up the module to automate the configuration of all Users’ Outlook profiles.

@ Launch DeploymentPro for UserActivation to View Legacy Projects

Module Configuration

Cancel Save and Continue

Destination Domain Name

@,

The field cannct be left blank

Select Destination Endpoint
Office365

14


https://help.bittitan.com/hc/en-us/articles/115008110847

T-N@S@

Once users start to login to their computers, their device will be registered and their primary
UPN will be listed “Primary Email Address” column

Search Customers
A a Customers Cardinal Transport Device Management D e p I Oym e nt PI’O

Cardinal Transport

veryi
O Oreniew DeploymentPro

SERVICE MODULES Use BitTitan PowerShell to schedule DeploymentPro for a large number of mailboxes. Read more.

Sk HealthCheck for Office 365 125 a0 1999058

e  DeploymentPro Total Users Total Devices Licenses Owned

A Customers © Cordinal Tansport © Device tanacement >+ DEPlOyMeNtPro

DeploymentPro Settings

Use BitTitan PowerShell to schedule DeploymentPro for a large number of mailboxes. Read more

126 80 1999059

Total Users Total Devices Licenses Owned

Sort ¥ (

& Primary Email Address Destination UPN Module Status @ @ @ @

Scheduled on Apr 9, 2018 11:30am 0 0 1 0
Scheduled on Apr 7, 2018 12:15pm 0 0 1 0
Scheduled on Apr 7, 2018 9:45am 0 0 1 0
Not scheduled 5 0 0 0
Not scheduled 1 0 0 0
Not scheduled 0 0 0

15
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9. Users computers will be listed and will have a "heartbeat". Once a user signs into the device
their email will be tied to the device in a one to one relationship.

a Customers Cardinal Transport Device Management C om p UterS

Services Computers
80 Computers
Computer Name Number of Users Agent Status
AR-DD4 1 s
ARDEB 1 '
AS400CONSOLE-PC 1 v
BILLINGSARAH 1 L4
BROKERAGEJD-CR 1 «/

A R e - vl

10.* If a status shows a ? symbol it most likely means the computer is shut down and the tool
has been able to find a heartbeat in over 4 hours*

CRDTAPP 2 v

CRDT-AR-DLS 1 7]

16
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11. Once all users have populated with a and have the DMA agent installed, Schedule the
cutover date for the agent to run on their computer. (This is after you cutover MX records)

Schedule DeploymentPro

Schedule for Profile Cutover

This is the date and time scheduled for DeploymentPro to run on your Users’ machines. The module will install on their devices at the
next heartbeat, and then run silently until:

Select a date

May 11th, 2018 11:30am

The time specified is (America/Denver).
Subscribed Users (no license required): 1

License Consumption
Users License per User Total Licenses Required
1 1 0

User Destination Email

The Destination email address is the email address of the new profile after it has been configured.

Source Email Destination User Principal Name

Cancel Schedule Cutover

*Note™ If there are multiple domains involved you will have to go to “settings” in the deployment
pro page and change the domain for the users who need the separate domain

17
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12. Once the agent is scheduled successfully, all users should change to a status of "running"

Total Users Total Devices Licenses Owned
Primary Email Address Destination UPN Module Status @ @
Scheduled on Apr 30, 2018 9:15am 0 0
Scheduled on Apr 30, 2018 4:00pm 0 0

Scheduled on Apr 30, 2018 9:15am 1 0

Scheduled on Apr 30, 2018 9:15am ( 0

13.If the status does not say "running" but remains in "scheduled" reschedule again until it
moves into a running status

14.If users are not being picked up with the GPO, troubleshoot with the one remote emote user:

Run Gpresult on their computer to see if the GPO is running

If the GPO is running, try running the exe manually to see if it is blocked but a firewall
setting

If it is blocked then create an exception to the firewall to allow the exe to run.

If it is not being blocked check to see if there are any web proxy settings that may be
blocking communication back to bittitan

15. *This completes the steps for setting up DMA via GPO. If you have completed this
successfully then move on to the next section. If you are deploying the agent via email, follow
steps 16-26.

Deploying DMA via EMAIL

16. In the BitTitan portal, go to All Customers and select the customer you created

18
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17. Click Add Users Through An Endpoint

i LEET - E—

Add Users to begin managing your Customers and delivering Services.

Add Users Through an Endpoint

Automatically add Users and Groups from existing cloud services.

Enable the Device Management Agent

Deploy a lightweight Agent on devices to import Users.

Add Users in Bulk

Import Users through a CSV file, without accessing your Customer's production environment.

Add Users with Quick Add

‘Add a User to MSPComplete.

18. Click Manage Endpoint>Add Endpoint

19
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19. Add the BAE Endpoint from the “Find my Service Provider” dropdown and Provide the
Administrative Credentials

*Note* This is found alphabetically under “Silversky”

ch New Endpoint

© W Learn About Adding Endpoints

Details
Endpoint Name

BAE

Service Provider

Exchange 2010/ 2013 v

From the drop-down menu, select a Service Provider. Based on your selection, we will complete the remaining fields
for you.

Endpoint Type

Exchange Server 2003+ v

Outlook Web Access URL

https://exchange.postoffice.net

® Provide credentials
Providing credentials at the endpoint level allows you to have a centralized set of credentials that can be used
across BitTitan products.

) Do not provide credentials.

Close Add

*Note* This will autodiscover users from BAE and populate them in the BitTitan portal

20
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20. From here you can select users by checking the box next their name and selecting “Enable
Device Management Through Email”

1 Selected Apply User Migration Bundle License Delete Users Enable Device Management Through Email
=] Primary Email Addre... User Principal Name First Name Last Name DMA Status License Expiration
Demouser@test.com Demouser@test.com Demo User (7] None

21.Enter a valid email in the “From” section of the template and click Send Email

Enable Device Management Through Email

Lol W 1 L L P L e

Email details
To change the list of recipients, go back to the Users list and update your selection.

You can use Markdown syntax to format your email. Click here for help.

Demouserftest.com

P
From
From
Enter email address
Subject
Action required: Install the BitTitan Device Management Agent on your computer.
Enter email subject
- Insert a placeholder - -
e
Hello {user_first_name},
# Important Announcement
We are currently planning a series of updates and improvements to our IT Services.
]

21
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*Note* You can white label this email specific to the content you want users to receive. This
email is specific to the user and cannot be forwarded to another user for them to click on the link
for the exe file. The User Simply clicks on a link to open up a new page and click on one more
link to download the exe file

22. Monitor users that successfully have the agent installed by going to Customers>Select
customers>Manage>Device Management>Deployment pro

*You will need to put in the destination domain and add the 365 endpoint*

DeploymentPro Cancel

What is DeploymentPro, and how does it work?

E DeploymentPro is a cleud-based solution that remotely configures and manages Users’ Outlook profiles.
« To start using DeploymentPro, launch the Device Management Agent.

« Once installed on Users' devices, set up the module to automate the configuration of all Users’ Outlook profiles.

@ Launch DeploymentPro for UserActivation to View Legacy Projects

Module Configuration

Destination Domain Name
@
-
The field cannot be left blank
Select Destination Endpoint
Office365 i

Once users start to login to their computers, thier device will be registered and their primary upn
will be listed “Primary Email Address” column

Cardinal Transport

W A Customers Cardinal Transport Device Management D e p I Oym e nt P ro

O Ovenew DeploymentPro

SERVICE MODULES Use BitTitan PowerShell to schedule DeploymentPro for a large number of mailboxes. Read more.
®¢  HealthCheck for Office 365 1 25 80 1 9990 58

& DeploymentPro Total Users Total Devices Licenses Owned

22
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A customers © Cordinal Tansport © Device anagement  DEPlOyMeNtPro

DeploymentPro Settings

Use BitTitan PowerShell to schedule DeploymentPro for a large number of mailboxes. Read more

126 80 1999059

Total Users Total Devices Licenses Owned

Sort ¥ 4

Primary Email Address Destination UPN Module Status @ @ @ @

Scheduled on Apr g, 2018 11:30am 0 0 1 0
Scheduled on Apr 7, 2018 12:15pm 0 0 1 0
Scheduled on Apr 7, 2018 9:45am 0 0 1 0
Not scheduled 5 0 0 0
Not scheduled 0 0 0
Not scheduled 0 0 0

23. Users computers will be listed and will have a "heartbeat". Once a user signs into the device
their email will be tied to the device in a one to one relationship.

w Customers Cardinal Transport Device Management C om p UterS

Services Computers

80 Computers
Computer Mame Number of Users Agent Status
AR-004 1 4
ARDEB 1 v
AS4A00CONSOLE-PC 1 v
BILLINGSARAH 1 L
BROKERAGEJD-CR 1 v

* If a status shows a ? symbol it most likely means the computer is shut down and the tool has
been able to find a heartbeat in over 4 hours*

CRDTAPP 2 v

CRDT-AR-DLS 1 7]

23
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24. Once all users have populated with a and have the DMA agent installed, Schedule the
cutover date for the agent to run on their computer. (This is after you cutover MX records)

Schedule DeploymentPro

Schedule for Profile Cutover

This is the date and time scheduled for DeploymentPro to run on your Users’ machines. The module will install on their devices at the
next heartbeat, and then run silently until:

Select a date

May 11th, 2018 11:30am

The time specified is (America/Denver).

Subscribed Users (no license required): 1

License Consumption
Users License per User Total Licenses Required
1 1 0

User Destination Email

The Destination email address is the email address of the new profile after it has been configured.

Source Email Destination User Principal Name

Cancel Schedule Cutover

*Note™ If there are multiple domains involved you will have to go to “settings” in the deployment
pro page and change the domain for the users who need the separate domain

24
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25. Once the agent is scheduled successfully, all users should change to a status of "running”

25 25 1999059
Total Users Total Devices Licenses Owned
Primary Email Address Destination UPN Module Status @ @
Scheduled on Apr 30, 2018 9:15am 0 0
Scheduled on Apr 30, 2018 4:00pm 0 0
Scheduled on Apr 30, 2018 9:15am 1 0
Scheduled on Apr 30, 2018 9:15am 0 0

26.1f the status does not say "running" but remains in "scheduled" reschedule again until it
moves into a running status

25
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Prep Work Phase 4: Setup BitTitan Project

1. In BitTitan Portal, Open MigrationWiz by clicking on waffle icon at top of the page>Click
Mailbox Migration

m ® Feedback @ Help~- O Purchase

& A

Computers SET.E'."'.-'E'}'S Document Migration Public Folder Cloud Storage
Migraticn Migraticn
4 L el
DeploymentPro: Userfctivation for HeakthCheck for
Last Mame CsP Office 365
o L
User EM : E
HealthCheck for Userfctivation Mailbax Migraticn
Azure
-

Perscnal Archive:

26
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Select a Project Type:

2. Click Create Project>Select Mailbox Project

Create a Mailbox Project

‘With Mailbox Projects, automartically migrate data related to the
User mailbox. With most configurations you can migrate email,
calendars, contact...

Create a Public Folder Praoject

Public Folder Projects fully automate the migration process of
moving Public Folders, including Public Folder structure and
permissions, from one..

Create an Archive Migration Service Project

With Archive Migration Services, you can migrate large-scale,
enterprise-level archived..

Create a Collaboration Project

'With Collzboration Projects, you can automatically migrate data
from one collaboration platform to...

=) Mailbox

= iOm

Create a Document Project

With Document Projects, automatically transfer all your data
(including your entire folder hierarchy) from one cloud storage
solutien to 2nothe...

Create a Persanal Archive Project

With Personal Archives, you can automatically migrate all of your
archived

Create a Cloud Storage Project

With Cloud Starage Prajects, migrate large-scale and
unstructured...

Create A Database Project

Database Projects enable you to migrate on-premises Microsoft
SQL Server 2005 and later to Microsoft SQL Server 2012 and
later, as well as Microsoft...

HE BB

2. Name the Project and select your customer from the dropdown>Click Next Step

With Mailbox Projects, automatically migrate data related to the User mailbox. With most configurations you can migrate

email, calendars, contacts, journals, tasks, and notes.

Project Name*

BAE to 365

Customer*

+ Save Project

27
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4. If you followed the steps for email deployment for the DMA agent you should be able to select
your endpoint from the dropdown. If you did not, Select New and fill out the fields as shown
below:

é'h New Endpoint

© W Learn About Adding Endpoints

Details
Endpoint Name

BAE

Service Provider

Exchange 2010/ 2013 v

From the drop-down menu, select a Service Provider. Based on your selection, we will complete the remaining fields
for you.

Endpoint Type

Exchange Server 2003+

Outlook Web Access URL

https://exchange.postoffice.net

® Provide credentials
Providing credentials at the endpoint level allows you to have a centralized set of credentials that can be used
across BitTitan products.

) Do not provide credentials.

Close Add

28



s @D

5. In the Destination Settings, Click New, and add the 365 endpoint. Providing the admin
credentials

A'h New Endpoint

Exchange server, Office 365, etc). Endpoints can be reused for projects across all BitTitan products, and are
managed from the Custorner Dashboard. Endpoints allow you to perform migrations, the discovery of Users and
Groups, and administrative action.

© W Learn About Adding Endpoints

Details

Endpoint Name

365

If you dor't know your Server Type, click the buttor:

=+ Find My Service Provider
Endpoint Type

Office 365 v

® Provide credentials
Providing credentials at the endpaint level allows you to have a centralized set of credentials that can be used
across BitTitan products.

() Do not provide credentials.
If credentials are not provided at the endpoint level, you will need to provide per-user credentials when using
the endpoint as part of your projects.

Administrator Username

Enter an administrator username

29
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6. Click “Save and Go to Summary” This tells you whats eligible to move and give you additional
KB articles you can reference:

E PROJECT SUMMARY
SOURCE DESTINATION

0

Exchange Server 2003+ Microsoft Office 365

Items Available for Migration

« Contacts ¥ Calendars ¥ Mail ¥ Journals ¥ Notes ¥ Tasks + Rules
@ Migration Guides © Need Help?
Here are relevant Migration Guides: Here are some Knowledge Base articles related to your current
* Hosted Exchange to Office 365 Migration Guide configuration:
e On-Premises Exchange 2003 to Office 365 Migration Guide * How do | create an administrator account for login?
¢ Should I use delegation or impersonation when performing my
migration?

What credentials are needed to migrate from Hosted Exchange?
How do I turn off Calendar Assistant in Office 365?
More Articles: Knowledge Base

+ Save Project

30
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7. Add items to your project. If you already added users to the MSP complete portal either
through GPO or an endpoint. You can select “Add from MSP Complete”. If you have not yet,
then you can select Autodiscover items to import users to the portal

# Edit Project =

Add items to your Project.

%o Add From MSPComplete

I L e sers from an exstng Customer

* Quick Add

u

Add one item at a time.

*» Quick Add
*s Bulk Add

4 Bulk Add

Use our online spreadsheet, or a file of your own, to add

it -
Click the "Add" menu in the toolbar, and select an option for o

adding items. =, Autodiscover ltems

Use MigrationWiz to automatically discover all of your items.

8. Audit User names and Domains on both the Source and Destination (Make sure they match
BAE and 365), Cleanup user list.

9. Select All Users>Verify Credentials

Source Email & Verify Credentials Last Updated Migrated User Migration Bundl...  Error Status

1 Demouser@test.com & Trial Migration May 9, 2018 2:49pm 0 bytes No @ 0 B Not Submitted £

@ Pre-Stage Migration

B Full Migration

7 Retry Errors
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10. There are numerous errors that could appear here. Most of the steps | made for prep work
will make it so that you avoid most of these errors. Refer to BitTitans KB articles for most
common errors and how to troubleshoot. https://help.bittitan.com/hc/en-
us/sections/115003465187-Mailbox-Error-Lookup?page=2

Unsuccessful verification will show a “Failed” Message

# EditProject ~

Source Email Destination Email Last Updated Migrated User Migration Bundl...  Error Status

< Demouser@test.com Demouser@test.onmicr...  May 9, 2018 2:53pm 0 bytes No @ 0 A Failed £ u

You can click on the Failed icon to show a detailed message of what failed

DEMOUSER@TEST.COM CROSOFT OFFICE

]
FOLDER SUMMARY MIGRATED ITEMS A MIGRATION ERRORS

A Your

Type Success Errors

No Data
Tota 0 (0 bytes) 0 (0 bytes)

This item hasn't started migrating o

Source Server uTes 31

0 of O folders completed

@ Learn More
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Click on “Learn More” to access BitTitan’s Relevant kb articles specific to the error:

© OFFICE 365 USER NAMES SHOULD ALWAYS BE SPECIFIED AS EMAIL
ADDRESSES

Office 365 user names should always be specified as email addresses: This error indicates that the specified Office

365 user name is invalid. Office 365 requires users to log in with an email address, not a user name as in "John
Doe" or "domain\johndoe”.

Resolution:

We recommend the following:

1. If using administrative credentials for Office 365, check the admin user name specified on your project.

2. If not using administrative credentials for Office 365, check the mailbox owner user name specified on the
mailbox.

3. In all cases, make sure the user name work when logging in at https://login.microsoftonline.com.

Close
Successful Verification will show a “Completed(Verification)” message
Source Email Destination Email Last Updated Migrated User Migration Bundl...  Error Status
| accounts-payable@vel..  accounts-payable@vel...  May 9, 2018 2:52pm 267.17KB No @ « Completed (Verifica... |

11. After all users have successfully completed verification, Select All users>Click on the
Hamburger icon at the top of the toolbar> Click Subscribe Users

+ o

Source Email Destination Email A HealthCheck

L Demouser@test.com Demouser@test.onmicr... Ma

Subscribe Users
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12. This will bring you back to the MSP complete portal. Select all users>Click Apply User
Migration Bundle

1 Users

1 Selected Apply User Migration Bundle License Delete Users Enable Device Management Through Email
= Primary E e User Princ e First Name Last Name oM atus L
v Demouser@test.com Demouser@test.com Demo User (7] !

13. This takes a couple of minutes to propagate but after, in the migrationwiz portal the “User
Migration Bundle” column will change from “No” to “Yes”

User Migration Bundl...

e

Migration Phase 1

1. Preferably start at beginning of the week, plan for MX Cutover on Friday evening

2. Select All Users>Click on the start button>Pre-stage Pass

s Source Email Y2 Verify Credentials Last Updated Migrated User Migration Bundl...
Ld Demouser@test.com & Trial Migration May 9, 2018 2:53pm 0 brytes Yes
& Pre-Stage Migration

E Full Migration

/ Retry Errors
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3. Select a time range from the dropdown of prior to 90 days>Start Migration

» Start Pre-Stage Migration

TS e DTET T, T L Epa 2t T 12 eer et o LT T Sy oCeTT TUeT TOETIE aTE TTNOTe ey Derauee
they do not change, but typically represent the majority of the data. Use this type of migration before MX record
cutover_ Fill the mailbox with older email; this reduces the amount of data to migrate after cutover.

u 1 Items Selected

0 Cannot Migrate

a 0 will migration using licenses.

a 1 will migrate using subscriptions.

Select what you want to migrate: (7] [ Remember my selection for this Project

Y = Mail
Migration Scheduling

Migrate isems with & date that is earlier than the specified date. @

A e hem -

[ Automnatically start the migration at @

X Cancel + Start Migration

4. This will give you a status bar and show the amount of data moved over in the “bytes”
column. If any users fail, it's usually do to server timeout. Simply rerun the pre-stage pass on
these users to restart where it left off. If you click on any user’s name, you can see metrics like

upload speeds:

MIGRATION HISTORY

Verify Credentials SASUEcEsS N 3 fow seconds
Start: May 9, 2018 2:51pm
End: May 9, 2018 2:52prm

Statistic

Active Duration

Full Migration SASiiecess 3 minutes
Start: May 8, 2018 6:51am n [ = 7] E
N = Data Speed
End: May &, 2018 6:55am — ata spee
o
Itern Speed
Full Migration SASiiecessl 2 minutes
Start: May 7, 2018 8:11pm n [ = 7] E

End: May 7, 2018 8:13pm

Full Mierarion
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Passive Duration

Source

6 minutes

Less than a second
3 MB/hr

97 itemns/hr

@ Performance Analysis

DURATION AND SPEED

Destination

a few seconds

6 minutes

146 MB/hr

5,597 items/hr
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5. Once the pre-stage migration has run for all users and is in a "Completed" Status

)
LR AR R

6. Next we are going to perform a full migration to bring over copies of remaining mail plus
calendars, contacts, notes, journals, rules. Select All users>Click on the start button>Full
Migration

s Source Email Y2 Verify Credentials Last Updated Migrated User Migration Bundl...

Ld Demouser@test.com & Trial Migration May 9, 2018 2:53pm 0 brytes Yes

& Pre-Stage Migration

E Full Migration

/ Retry Errors
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7. You can schedule this to start at a specific time if you would like:

» Start Full Migration

What is a Full Migration? @

Use this type of migration for Big Bang (Single-Pass) Migrations, or for following an earlier Pre-Stage Migration.
Use this after MX record cutover to make sure you are not missing any data.

u 1 Items Selected a 0 will migration using licenses.

0 Cannot Migrate a 1 will migrate using subscriptions.
Select what you want to migrate: (7 [ Remember my selection for this Project.
¥ B contacts ¥ £ calendars ¥ = mail ¥ W Journals
¥ & Notes s Tasks ¥ & Rules

Migration Scheduling

¥ Automatically start the migration at @

kn
-

10 v

[
[
et
(5]
-
=]
-
[
-
]
i1}
|
]
|

¥ Cancel + Start Migration

8. Confirm all users go into a "Completed” Status
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Migration Phase 2: MX Cutover/Delta Pass

At Designated time, login to DNS provider and change you MX records to point to
Office365
a. You can find this in the 365 Admin Center by going to Setup>Domains
b. Office365 MX record follow this format Domain-
com.mail.protection.outlook.com

Run another Full Pass. This will perform a delta sync to pull over any residual data that
may have been missed.

Migration Phase 3: Post Migration Cleanup

Audit Destination Environment Mailflow for Inbound/Outbound Mail
Login to BitTitan>Go to All customers>Select customer>Manage>Device

Management>Deployment Pro

Make sure DMA status has moved into "Completed" status. If in "error" status it means
the users failed authentication 3x. Reschedule the tool to run at the next time interval
available
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A customers o CEl > bevieeManegement © DEPlOyMENtPro

DeploymentPro Settings
Use BitTitan PowerShell to schedule DeploymentPro for a large number of mailboxes. Read more x
Total Users Total Devices Licenses Owned
Sot v || Q

Primary Email Address Destination UPN Module Status @ @ @ @

Scheduled on May 4, 2018 1:00pm 0 0 1 0
Scheduled on May 7, 2018 11:00am 0 0 1 0
Scheduled on May 7,2018 11:00am 0 0 1 0
Scheduled on May 7,2018 11:00pm 0 0 1 0
Scheduled on May 4, 2018 1:00pm 0 0 1 0
Scheduled on May 4,2018 1:00pm 0 0 1 0

4. Reconfigure any mailbox permissions

5. Send out guides on reconfiguring mail on Iphone/Andriod:
a. https://support.office.com/en-us/article/set-up-email-using-the-ios-mail-app-
7e5b180f-bc8f-45cc-8dal-5cefcle633dl
b. https://support.office.com/en-us/article/set-up-email-in-android-email-app-
71147974-7

6. Perform and account clean up that is required
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